lime-go - Temporary Email Delivery Disruption – Incident details

Newsletter experiencing degraded performance

Temporary Email Delivery Disruption

Monitoring
Partial outage 30 %
Started 1 day ago

Affected

Newsletter

Partial outage from 1:43 PM to 2:02 PM, Degraded performance from 2:02 PM to 12:00 AM

Updates
  • Monitoring
    Monitoring

    The affected IP/domain has now been successfully whitelisted, and email delivery has returned to normal.

  • Identified
    Identified

    We identified an issue where a large outbound email campaign resulted in a high number of bounced recipients. This triggered automated protections in our email infrastructure, causing our Lime Go sending domain to be temporarily blacklisted.

    This was not due to a security breach, but rather standard safeguards designed to prevent spam or misuse.

    We have taken corrective actions together with our email provider, and the domain is in the process of being restored/whitelisted.